Support for Angular and AngularJS framework in JavaScript analyzer

The JavaScript analyzer now detects issues in Angular (v2.0 and above) and AngularJS (v1.x) code. The analyzer detects 58 issues in AngularJS code, and 34 issues in Angular code. Read the full changelog here.